회원로그인



 

자유게시판

Winamp 프로그램 파일 처리 취약점 패치 권고

페이지 정보

작성자 화니 쪽지보내기 메일보내기 자기소개 아이디로 검색 전체게시물 작성일06-02-10 23:28 조회11,968회 댓글0건

본문

출처 : 인터넷 침해사고 대응지원센터 http://www.krcert.or.kr
일자 : 2006-01-31
□ 개요
o 각종 오디오 파일과 비디오 파일을 재생할 수 있는 Winamp 프로그램에 대한
보안취약점과 공격코드가 발표되어 해킹 수단으로 악용될 경우 사용자들의
피해가 우려됨
- Winamp 사용자들은 최신버전(5.13)으로 신속하게 패치를 하여야 함
□ 설명
o Winamp가 악의적으로 작성된 플레이리스트 파일을 읽을 때 경계 처리 문제가 발생함
※ 플레이리스트(Playlist) 파일 : 재생 목록을 저장한 파일(*.pls, *.m3u 등)로
Winamp 등의 매체 재생기 프로그램에서 사용됨
o 공격자는 악의적으로 작성한 플레이리스트 파일을 이용하여 아래와 같은 방법으로
피해를 유도할 수 있음
- 악의적으로 작성한 플레이 파일을 IFRAME 태그 등을 포함한 웹 사이트를 구성하고
해당 웹 사이트를 방문하도록 유도
- 악의적으로 작성한 플레이리스트 파일을 이메일 첨부물 등으로 포함하여
실행하도록 유도
- P2P 프로그램 등을 통해 악의적으로 작성한 플레이리스트 파일을 공유하여
해당 파일을 실행하도록 유도
- 기타 다양한 방법을 통해 플레이리스트 파일을 실행하도록 유도
o 공격이 성공할 경우 공격자가 피해 시스템에서 임의의 명령 실행이 가능
(백도어 및 트로이잔 설치 등)
□ 해당 시스템
o 영향 받는 소프트웨어
- 5.12버전과 이전 버전의 Winamp
※ 현재 사용 버전 확인방법 : Winamp 메인 메뉴에서 "Nullsoft Winamp" 항목을 선택
□ 해결 방법
o 해당 소프트웨어를 최신버전(Winamp 5.13)으로 업데이트
□ 참고사이트
[1] http://www.winamp.com
[2] http://secunia.com/advisories/18649/
====================================================
□ FAQ
1. Winamp 소프트웨어 취약점과 패치버전은 언제 발표되었나요?
- 관련 취약점이 한국시각으로 1월 31일 발표되었으며, 소프트웨어 제작사(Nullsoft)에서
1월 31일에 해당 취약점을 패치한 최신버전(5.13)을 발표하였습니다.
2. 현재 사용중인 Winamp가 해당 취약점에 영향을 받는 지 여부는 어떻게 확인하나요?
- 금일 아침에 해당 취약점을 패치한 최신버전이 나왔으므로, 금일 업데이트 하지
않은 Winamp 사용자는 모두 취약합니다. 버전 확인하는 방법은 Winamp 메인
메뉴에서 "Nullsoft Winamp" 항목을 선택하면 팝업이 뜨며 아래쪽에 버전 정보가 나오고
5.13 버전보다 숫자가 낮은 버전은 모두 취약합니다.
3. 악의적으로 작성된 플레이리스트 파일이 삽입된 사이트를 방문하는 경우 해당
취약점으로 인해 모두 해킹이 되나요?
- Winamp가 아닌 미디어플레이어, 제트오디오, 곰플레이어, 곰오디오 등
다른 프로그램으로 플레이리스트 파일을 재생시키게 설정되어 있으면 영향을 받지
않습니다. 또한, Winamp도 최신버전(5.13)으로 업데이트 되어 있으면 영향을 받지
않습니다.

댓글목록

등록된 댓글이 없습니다.

자유게시판 목록

게시물 검색

 

개인정보취급방침 서비스이용약관 Copyright © 2004~2019 ☊ Gasazip.com All rights reserved.   / 퍼니즈 쇼핑 / E-mail : hwanico@gmail.com RSS